Next Session hotkey.

WinEQ 2.0 Pro discussion and support

Moderators: Lavish Software Team, Moderators

Post Reply
banchicawawo
GamingTools Subscriber
Posts: 6
Joined: Tue Jan 01, 2008 12:41 am

Next Session hotkey.

Post by banchicawawo » Mon Jun 26, 2017 9:24 am

So, Ctrl+Alt+1 and Ctrl+Alt+2 are kind of a pain for me to activate, so I wanted to simply change the Next Session hotkey to Ctrl+T, but that doesn't seem to work. I tried both Ctrl+T and Ctrl+t. I thought maybe the capital T meant it was expecting a shift on the T and maybe that's why it wasn't working. I have changed the preference, logged out of EQ completely, closed WinEQ2 from running, and then loaded the app from scratch. Still no luck.

I know most browsers use Ctrl+T for a new tab, but I wasn't sure if this was some kind of special reserved keystroke combination by the OS. I'd like something very fast so I don't have to use Ctrl+Alt+# to get to the next screen.

I am only 2 boxing, so Ctr+T would make it really easy to swap from one to the other over and over again (a single hotkey that cycles back and forth basically).

Any ideas?

Thanks.

Lax
Owner
Posts: 6632
Joined: Fri Jun 18, 2004 6:08 pm

Post by Lax » Mon Jun 26, 2017 12:32 pm

Next Session is not being registered as a global hotkey -- only the "Global Activation <#>" hotkeys are set up this way. All others (including Next Session) are interpreted directly by WinEQ 2, within the game windows. If you're using a browser at the time, and you press Ctrl+T intending for it to switch EQ windows, it's just going to open a browser tab.

So there is no conflict with the OS or browsers in this case. I don't see why Ctrl+T wouldn't work. But what I would suggest is that on the Hotkeys preferences section, at the top is "Key Name List". Make sure what you're entering appears in this list (if Windows is set up with US English then I don't see why not).

Otherwise it sounds like you're doing the right thing. Have you tried entering any other combination besides Ctrl+T to see if something else works for you? (Capitalization does not matter)

banchicawawo
GamingTools Subscriber
Posts: 6
Joined: Tue Jan 01, 2008 12:41 am

Post by banchicawawo » Mon Jun 26, 2017 8:08 pm

Ok, so I'm not sure what I'm doing wrong here. I specifically tried to use "Right Ctrl" + "T" but the Next Session field does not allow any spaces, so I am confused. In the drop down list, it specifically shows "Right Ctrl under the Key Name List. So, I tried:
Right Ctrl+T
"Right Ctrl+T"
'Right Ctrl+T'

It doesn't like single or double quotes, and it doesn't like the space. How do you actually specify Right control? I tried regular control, and it accepts that expression, but then it does not actually work.

I was originally expecting it to accept my key input by actually hitting the ctrl key and then pressing the T key, but it looks like it wants you to actually type out the expression. Is this correct?

Also, do I have to have EQ PlayNice enabled in order to make these hotkeys work? I usually have it disabled because I don't care for FPS limiting. I'm only running 2 instances, and I want auto-follow to work, so I disabled EQ PlayNice to boost performance, and I'm wondering if that has something to do with it.

Thanks.

banchicawawo
GamingTools Subscriber
Posts: 6
Joined: Tue Jan 01, 2008 12:41 am

Interesting!

Post by banchicawawo » Mon Jun 26, 2017 8:10 pm

Ok, so after tinkering some more, I found that LEFT control + T is working fine, but not Right control. It sounds strange, but the key on my mouse (naga 2014 edition) that I use is bound to Right control, but in every other game, it registers as Control and Right Control, so I'm not sure why WinEQ2 is ONLY registering it as a Left control.

So, going to my question above, is there a way to make it register as Right Control? I must be goofing the Syntax somehow.

Thanks again.

Post Reply