Visual Studio Paths

From Lavish Software Wiki
Jump to: navigation, search

Overview

Visual Studio keeps a list of default paths for includes and library files in order to make things easier when developing. When a file to include resides in one of the default paths, it can be included by surrounding the filename with <> rather than "", and the path can be omitted. For example, #include <isxdk.h>, rather than #include "c:\program files\inner space\isxdk\include\isxdk.h". This also makes things easier when sharing your source code with others, so their directory structure does not need to match yours.

Visual Studio 2010

  1. Drop down the Project menu and select your project properies (Alt+F7)
  2. In the box on the left is a list of option categories. Select "Configuration Properties", and then the sub-category "VC++ Directories".
  3. In the middle of the right hand side of the window is a list of directories. Add the include path by pressing the "New Line" button above the window, or by pressing "Ctrl-Insert". A blank entry appears for you to either type the path or navigate by clicking the "..." button. Generally the final path you want will end with a folder called "include". Enter the path now (ie, c:\program files\isxdk\include)
  4. Select "Library files" in the drop-down box
  5. In the same fashion as done for the include file path, add the path to the library files. (ie, c:\program files\isxdk\32\lib\vs10)
  6. You're done, click OK

Visual Studio 2005, 2008

  1. Drop down the Tools menu, and select Options
  2. In the box on the left is a list of option categories. Select "Projects and Solutions" and then the sub-category "VC++ Directories"
  3. In the upper right hand corner is a drop-down box that selects a particular set of default directories, including "Executable files", "Include files", "Reference files", "Library files", and "Source files". Generally, you only want to add to the "Include files" or "Library files" lists. Select "Include files"
  4. In the middle of the right hand side of the window is a list of directories. Add the include path by pressing the "New Line" button above the window, or by pressing "Ctrl-Insert". A blank entry appears for you to either type the path or navigate by clicking the "..." button. Generally the final path you want will end with a folder called "include". Enter the path now (ie, c:\program files\isxdk\include)
  5. Select "Library files" in the drop-down box
  6. In the same fashion as done for the include file path, add the path to the library files. (ie, c:\program files\isxdk\lib\vs80)
  7. You're done, click OK


Visual Studio .NET 2002, 2003

  1. Drop down the Tools menu, and select Options
  2. In the box on the left is a list of option categories. Select "Projects" and then the sub-category "VC++ Directories"
  3. In the upper right hand corner is a drop-down box that selects a particular set of default directories, including "Executable files", "Include files", "Reference files", "Library files", and "Source files". Generally, you only want to add to the "Include files" or "Library files" lists. Select "Include files"
  4. In the middle of the right hand side of the window is a list of directories. Add the include path by pressing the "New Line" button above the window, or by pressing "Ctrl-Insert". A blank entry appears for you to either type the path or navigate by clicking the "..." button. Generally the final path you want will end with a folder called "include". Enter the path now
If the desired library uses a lib file, continue following the steps. If not, you're done. Just click OK.
  1. Select "Library files" in the drop-down box
  2. In the same fashion as done for the include file path, add the path to the library files. (ie, c:\program files\isxdk\lib\vs70)
  3. You're done, click OK

Alternate Method .NET 2002 and 2003

  1. In the Solution Explorer, select all the projects that start with ISX (all but Solution Items)
  2. Right click and choose Properties
  3. Under Configuration Properties -> C/C++ -> General, add the ISXDK path ending with include to Additional Include Directories
  4. If library path is required (yes), add ISXDK path ending in lib\vs70 to Addition Library Directories

Visual Studio 6

  1. Drop down the Tools menu, and select Options
  2. Click on the Directories tab. It should be tab number six.
  3. In the upper right hand corner is a drop-down box that selects a particular set of default directories, including "Executable files", "Include files", "Reference files", "Library files", and "Source files". Generally, you only want to add to the "Include files" or "Library files" lists. Select "Include files".
  4. In the bottom-middle of the window is a list of directories. Add the include path by pressing the "New" button above the list of directories. A blank entry appears for you to either type the path or navigate by clicking the "..." button. Generally the final path you want will end with a folder called "include". Enter the path now. As an example, my install path was "C:\Program Files\ISXDK\Include"
If the desired library uses a lib file, continue following the steps. If not, you're done. Just click OK.
  1. Select "Library files" in the drop-down box in the upper right hand corner of the window.
  2. In the same fashion as done for the include file path, add the path to the library files. Generally the final path will end with a folder called "lib". As an example, my install path was "C:\Program Files\ISXDK\Lib".
  3. You're done, click OK.