press enter

Discussion of Inner Space

Moderators: Lavish Software Team, Moderators

Post Reply
bountycode
Non-Subscriber
Posts: 22
Joined: Mon Jul 12, 2004 8:27 am

press enter

Post by bountycode » Fri Mar 25, 2005 9:20 pm

the press enter in EQ2 does not seem to work now.
This code:

console off
wait 50
type /quit
press enter

the code works all the way up to the press /quit part but does not process the press enter

Lax
Owner
Posts: 6632
Joined: Fri Jun 18, 2004 6:08 pm

Post by Lax » Fri Mar 25, 2005 11:33 pm

yeah funny thing about that, Sony decided they had no idea what input system they use so enter and backspace both use a different input system in the chat box than everything else (as of bloodline chronicles update). I'll come up with something, thanks for the report

bountycode
Non-Subscriber
Posts: 22
Joined: Mon Jul 12, 2004 8:27 am

Post by bountycode » Sat Mar 26, 2005 9:43 am

That Sony. lol. what are they doing. Thanks for looking into this.

bountycode
Non-Subscriber
Posts: 22
Joined: Mon Jul 12, 2004 8:27 am

Post by bountycode » Sun Mar 27, 2005 6:30 am

just wondering if the Shift and Alt keys are doing a similar thing.
On the hot bars you have numbers 0 to 9 Shift+0 to Shift9 and Alt+0 to Alt+9 and code that presses just the numbers 0 to 9 works but there does not seem to be any way to press the alt+0 to alt+9 or shift+0 to shift+9 keys.

I've tried
Press Alt+0
only the 0 gets processed. and
Press -hold Alt
Press 0
again only the 0 gets processed

Lax
Owner
Posts: 6632
Joined: Fri Jun 18, 2004 6:08 pm

Post by Lax » Sun Mar 27, 2005 2:12 pm

I'll do some tests

Lax
Owner
Posts: 6632
Joined: Fri Jun 18, 2004 6:08 pm

Post by Lax » Mon Mar 28, 2005 1:06 am

Inner Space 0.77 should fix this problem. However, you need to go into the Games window, and for EverQuest II, in the "Input Systems", turn on Win32I Keyboard. Then hit apply.

With that enabled, it should all work. Give it a shot with Press Alt+O, press enter, etc

bountycode
Non-Subscriber
Posts: 22
Joined: Mon Jul 12, 2004 8:27 am

Post by bountycode » Thu Mar 31, 2005 8:06 am

ok press enter now works :)
but Press Alt+1 does not, it still only hits the number1 hot key and not the Alt1 hot key.

Lax
Owner
Posts: 6632
Joined: Fri Jun 18, 2004 6:08 pm

Post by Lax » Thu Mar 31, 2005 1:05 pm

That's with Win32I on? hmm... I'll look into it

bountycode
Non-Subscriber
Posts: 22
Joined: Mon Jul 12, 2004 8:27 am

Post by bountycode » Thu Mar 31, 2005 9:00 pm

Yes Win32I is on
Thanks

Lax
Owner
Posts: 6632
Joined: Fri Jun 18, 2004 6:08 pm

Post by Lax » Fri Apr 08, 2005 10:04 am

After several hours of trying to figure this out, I've concluded that alt must be held for a frame to press alt+1 in EQ2. I tested it successfully in the console like so:
"console off;press -hold alt;press 1;timed 1 press -release alt"

In a script you can use waitframe instead

Lax
Owner
Posts: 6632
Joined: Fri Jun 18, 2004 6:08 pm

Post by Lax » Sat Apr 09, 2005 9:41 pm

I have this fixed up in IS 0.83 so you can do press alt+1 without the wait/timed workaround

Post Reply