Alt F4 Global activation key with windows 10

WinEQ 2.0 Lite discussion

Moderators: Lavish Software Team, Moderators

Post Reply
jackson55
Non-Subscriber
Posts: 5
Joined: Wed Feb 10, 2016 12:25 pm

Alt F4 Global activation key with windows 10

Post by jackson55 » Sun Jul 31, 2016 8:25 pm

hello and thank you.

I play everquest 1.

for my global activation keys i like using alt + F1 through alt + F12.

with windows 8 using alt + f4 was fine. pressing alt + f4 would not close any window, it properly activated the EQ window.

now i updated to windows 10 and alt + f4 closes what ever window is active.

for now i have switched it to crtl + f4, but old muscle memory of pressing alt + f4 is becoming frustrating.

is there any fix to this? or do i have to suck it up and cant use alt + f4 anymore?

thanks again

Lax
Owner
Posts: 6632
Joined: Fri Jun 18, 2004 6:08 pm

Post by Lax » Sun Jul 31, 2016 9:31 pm

A quick Google confirms that Alt+F4 is no longer allowed by the RegisterHotkey API in Windows 10. It does sound like you'll need to change your setting -- sorry!

I am surprised it worked before to be honest.

jonesy
GamingTools Subscriber
Posts: 31
Joined: Thu Nov 17, 2011 9:49 am

Post by jonesy » Sun Jul 31, 2016 9:46 pm

There are registry keys you can use to disable all the Windows global hotkeys, although they don't specifically refer ALT+F4, and allude to the WIN key, YMMV (mainly because I think ALT+F4 is a local window hotkey rather than global).

It is possible that it could be coded to trap the ALT+F4 if a particular process is open, and people do using AutoHotKey (https://autohotkey.com/docs/misc/Override.htm , http://us.battle.net/forums/en/wow/topic/2030264429). No idea if this still works on Win10.

Post Reply