EverQuest 1 Bug: No character select window in 640x480

Announcements from the Lavish Software team
Post Reply
Lax
Owner
Posts: 6632
Joined: Fri Jun 18, 2004 6:08 pm

EverQuest 1 Bug: No character select window in 640x480

Post by Lax » Tue Nov 01, 2005 7:40 pm

A few users complained that the character select window no longer appears for them in 640x480. I set my EQ resolution to 640x480 and verified that it does not appear.

I looked around for stored positions of the character select window and found none. I then checked EQUI_CharacterSelect.xml, and the size of CharacterSelectWindow is 252x484. I formed a hypothesis: The character select window may not be appearing because for some reason EQ has code written in it to not display windows that are larger than the screen. To test the hypothesis, I merely changed the value 484 to 480, the exact size of the screen, and logged back into EQ. Voila! The character select window appears. This is an unfortunate short-sightedness from SOE, and whatever code has this effect should probably be removed.

If you run EverQuest in a low resolution, you will need to customize your character select window with a UI mod (if that's even supported for character select) and/or report this bug to Sony! You CAN disable patching through WinEQ and make the following change to EverQuest\uifiles\default\EQUI_CharacterSelect.xml

Code: Select all

	<Screen item="CharacterSelectWindow">
		<!--<ScreenID/>-->
		<!--<Font/>-->
		<RelativePosition>false</RelativePosition>
		<Location>
			<X>0</X>
			<Y>20</Y>
		</Location>
		<Size>
			<CX>252</CX>
			<CY>[color=red]480[/color]</CY>
		</Size>

Post Reply